Troubleshoot Rolling Update

This section helps you identify and resolve some issues that you might encounter when using the rolling update.

The publish result is timeout after the publish completes

The publish log shows deployment exceeded its progress deadline.


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Cause

The timeout shown in the publish result indicates that the publish deployment time exceeds the timeout configured in the deployment stage, which does not mean the publish failed.

Solution

To double-check if the application is published successfully:.

  1. Click View Pods operation status to view pod status.

  2. If the pod is Running, check if the image tag is the same as the image selected in the publish form.


    ../../_images/trouble1.1.png

The default timeout is 10 minutes. Contact EnOS technical support to modify the timeout value if you want to prevent publish timeout.

Pod failed during publishing

The pod status is failed and the deployment information shows Liveness probe failed or Readiness probe failed.


../../_images/trouble3.2.png


Cause

The publish is not yet complete and the probe ran longer than the timeout period.

Solution

View the Pod logs and confirm if the service is starting correctly in the Logs tab.

  1. Click View Pods operation status to go to the Pods list.


    ../../_images/trouble2.1.png
  2. Click the Pod name to go to the Pod details page.


    ../../_images/trouble2.2.png
  3. Click the Log tab to check if any errors are reported in the log.


    ../../_images/trouble2.3.png


If there is no error in the log, extend the liveness probe or readiness probe timeout.

  1. From the left navigation bar, select Container > Deployments.

  2. Click the edit icon on the right side of the application to go to the Edit Deployment page and adjust the timeout for the liveness probe or the readiness probe.


../../_images/trouble3.1.png