单元三:配置岗位工作台页面


操作人

操作地点

应用构建者

EnOS 应用门户


本单元以风电行业的岗位工作台页面为例,介绍应用构建者配置数字孪生可视化指标页面的具体步骤。岗位工作台页面示例如下所示。


../_images/sample.png


你也可以下载 岗位工作台样例页面 并将其导入到数字孪生可视化中,快速复用如上页面或查看页面中的具体配置。有关导入数字孪生可视化页面的更多信息,参见 导入项目、页面模板和组件模板。

备注

此样例页面适用于数字孪生可视化 2.4.0 及以上版本。

前提条件


开始之前,确保以下事项:

  • 当前帐号已被分配所需的资产权限、操作权限点和包含 指标工具 > 指标页面 的菜单组。如未分配,联系应用管理员。

  • 当前 OU 的数字孪生可视化指标工具中包含 SaaS 组件。如未包含,联系系统管理员。

步骤 1:创建项目和页面


在数字孪生可视化中,应用构建者通过指标页面实现指标数据的可视化,通过项目对指标页面进行分组管理。通过以下步骤新建项目并在新项目中创建岗位工作台页面:

  1. 登录 EnOS 应用门户,并在应用列表中选择 数字孪生可视化。

  2. 在左侧导航栏中选择 指标工具 > 指标页面。

  3. 选择 新建项目,在弹窗中输入 岗位工作台 作为项目名称并选择 确定。

  4. 选择 新建页面,在弹窗中输入以下信息:

    • 名称:输入 风电岗位工作台。

    • 项目:选择 岗位工作台,即新创建的项目。


创建页面后将自动跳转至 页面编辑器。你需要在页面编辑器中进行配置页面属性、添加组件等操作。

步骤 2:设置页面属性


创建页面后,通过以下步骤配置页面的基本属性,包括主题、颜色等信息:

  1. 在页面编辑器的顶部工具栏中,选择 页面设置 i_pagesetting 打开页面设置面板。

  2. 在页面设置面板中输入以下信息。


    配置

    描述

    主题

    选择 dark。

    组件标题栏高度

    输入 36。

    组件标题栏颜色

    将颜色代码中 A 的参数值设置为 0,即将组件标题栏颜色设置为透明。


有关页面设置配置项的更多信息,参见 自定义页面属性。

步骤 3:配置页面


考虑到风电领域终端用户的工作需求,岗位工作台页面中需要展示以下内容:

  • 访问监测、告警、指标查询等常用页面的快捷入口

  • 场站和设备运行状态的统计

  • 总体安全运行状况和节能减排指标

  • 当日发电量、平均风速等关键实时数据

  • 实际发电量、计划发电量以及发电计划的完成率

  • 处于异常状态的设备和异常概况

  • 场站关键指标的排名

  • 资产服务请求和告警列表

备注

  • 本单元仅包含确保组件或容器正常显示的必要配置项,应用构建者可以根据显示器大小与分辨率等因素调整其他配置项(如字体、字号和页边距等),从而获得最佳显示效果。

  • 由于不同 OU 注册的属性、指标和测点不同,本单元涉及的数据项名称可能与具体场景有所差异。

添加容器


为了让指标页面保持清晰整洁并对同类型组件进行分组管理,在搭建岗位工作台页面的过程中,通过以下步骤创建用于分组存放组件的 容器:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 容器 打开容器设置弹窗。

  2. 在 基本选项 标签页中输入以下信息。


    配置

    描述

    标题

    输入 常用应用入口。

    隐藏标题

    启用此功能。


  3. 在 容器样式 标签页中输入以下信息。


    配置

    描述

    页签

    输入 常用应用入口。

    页签样式

    选择 卡片 和 标题下。

    页签颜色

    在 选中 下拉框中将颜色代码中 A 的参数值设置为 0,即将页签颜色设置为透明。


  4. 选择 确定。


重复以上步骤,再向页面中添加 8 个容器,并按照下表配置各个容器的标题、页签名称和页签样式(其他配置与上述步骤中的相同)。


编号

标题名称

页签名称

页签样式

1

输入 场站运行情况。

输入 场站运行情况。

选择 卡片 和 标题下。

2

输入 设备运行情况。

输入 设备运行情况。

选择 卡片 和 标题下。

3

输入 安全运行天数。

输入 安全运行天数。

选择 卡片 和 标题下。

4

输入 节能减排。

输入 节能减排。

选择 卡片 和 标题下。

5

输入 实时数据。

输入 实时数据。

选择 卡片 和 标题下。

6

输入 完成率。

选择 添加,添加一个新页签。分别输入 当月 和 当年 作为页签名称。

选择 按钮 和 标题右。

7

输入 异常设备统计。

输入 异常设备统计。

选择 卡片 和 标题下。

8

输入 资产排行。

输入 场站排行。

选择 卡片 和 标题下。

向容器中添加组件


容器创建完成后,通过以下步骤配置可视化组件并将配置完成的组件移动到各个容器中。

常用应用入口


常用应用入口容器是让终端用户快速访问监测、告警、查询等常用页面的快捷入口,包含以下组件:

  • 跳转到资产概览页面的图片组件

  • 跳转到风电资产列表页面的图片组件

  • 跳转到健康预警页面的图片组件

  • 跳转到综合查询页面的图片组件


图片组件用于展示特定图片,并支持为图片添加链接,终端用户在选择图片组件时即可跳转到指定页面。更多信息,参见 图片。通过以下步骤配置图片组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 图片 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 开启图表设置面板右上角的 展开全部配置。

  4. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  5. 在 图表样式 标签页中输入以下信息。


    配置

    描述

    Type

    选择 upload,即从本地上传图片。

    File

    选择 上传文件 并在弹窗中上传 资产概览.png。

    图片跳转

    选择 跳转设置,在弹窗中输入资产概览页面的 URL 地址。


  6. 选择 确定。

  7. 将光标悬停到图片组件的省略号图标(…)上,选择 克隆组件 并重复 3 次。

  8. 将光标悬停到克隆出的图片组件的省略号图标(…),选择 编辑 并依次在图表设置面板的 图表样式 标签页中输入以下信息。


    编号

    File

    图片跳转

    1

    上传 风电.png。

    选择 跳转设置,在弹窗中输入风电页面的 URL 地址。

    2

    上传 健康预警.png。

    选择 跳转设置,在弹窗中输入健康预警页面的 URL 地址。

    3

    上传 综合查询.png。

    选择 跳转设置,在弹窗中输入综合查询页面的 URL 地址。


  9. 将光标悬停到 资产概览 图片组件上选择 添加到容器 并在容器列表中选择 常用应用入口 > 常用应用入口。

  10. 重复上述操作,将所有配置完成图片组件移动到 常用应用入口 容器中。

  11. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的常用应用入口容器如下图所示。


../_images/appentry.png

场站运行情况


场站运行情况展示当前处于特定状态(如故障、维护等)的场站数量,包含一个展示场站状态标签和相应场站数量的多度量卡组件。多度量卡组件用于展示资产的多个指标或测点等数据。更多信息,参见 多度量卡。通过以下步骤配置多度量卡组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。
    此处 EnOS_Wind_Farm 和其他可选项目均为 EnOS 管理控制台中的模型。有关模型的更多信息,参见 模型与资产建模。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,依次添加 场站数、正常运行、有故障、有维护 和 无连接。


  5. 依次选择各个度量名称左侧的箭头图标 i_rarrow 为度量配置展示在组件中的 别名。


    度量

    别名

    场站数

    输入 所有场站。

    正常运行

    输入 正常发电。

    有故障

    输入 故障。

    有维护

    输入 维护。

    无连接

    输入 通讯中断。


  6. 在 图表样式 > 度量样式 部分中各个度量输入以下信息。


    度量

    配置

    场站数

    显示名称:启用此功能。
    小数位数:选择 0。
    使用填充色:启用此功能。
    名称框填充色:选择 蓝色(0A84FF)。

    正常运行

    显示名称:启用此功能。
    小数位数:选择 0。
    使用填充色:启用此功能。
    名称框填充色:选择 绿色(08D08C)。

    有故障

    显示名称:启用此功能。
    小数位数:选择 0。
    使用填充色:启用此功能。
    名称框填充色:选择 红色(F54E5F)。

    有维护

    显示名称:启用此功能。
    小数位数:选择 0。
    使用填充色:启用此功能。
    名称框填充色:选择 橙色(FF7633)。

    无连接

    显示名称:启用此功能。
    小数位数:选择 0。
    使用填充色:启用此功能。
    名称框填充色:选择 灰色(909090)。


  7. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 1 行 5 列。

    显示“展开”

    禁用此功能。


  8. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 场站运行情况 > 场站运行情况。

  9. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的场站运行情况容器如下图所示。


../_images/sitestat.png

设备运行情况


设备运行情况展示当前处于特定状态(如故障、维护等)的设备数量,包含一个展示设备状态标签和相应设备数量的多度量卡组件。通过以下步骤配置多度量卡组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,依次添加 正常运行设备数、故障设备数、维护设备数 和 通讯中断设备数。


  5. 依次选择各个度量名称左侧的箭头图标 i_rarrow 为度量配置展示在组件中的 别名。


    度量

    别名

    正常运行设备数

    输入 正常运行。

    故障设备数

    输入 故障。

    维护设备数

    输入 维护。

    通讯中断设备数

    输入 通讯中断。


  6. 在 图表样式 > 度量样式 部分中为各个度量输入以下信息。


    度量

    配置

    正常运行设备数

    图标:选择 默认。
    图标颜色:选择 绿色(08D08C)。
    显示名称:启用此功能。
    小数位数:选择 0。

    故障设备数

    图标:选择 警告。
    图标颜色:选择 红色(F54E5F)。
    显示名称:启用此功能。
    小数位数:选择 0。

    维护设备数

    图标:选择 工单。
    图标颜色:选择 橙色(FF7633)。
    显示名称:启用此功能。
    小数位数:选择 0。

    通讯中断设备数

    图标:选择 健康状况。
    图标颜色:选择 灰色(909090)。
    显示名称:启用此功能。
    小数位数:选择 0。


  7. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 1 行 4 列。

    显示“展开”

    禁用此功能。


  8. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 设备运行情况 > 设备运行情况。

  9. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的设备运行情况容器如下图所示。


../_images/devicestat.png

安全运行天数


安全运行天数展示风电场站安全运行的累计时长,包含一个统计安全运行天数的多度量卡组件。通过以下步骤配置多度量卡组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,添加 安全运行天数。


  5. 在 图表样式 > 度量样式 > 安全运行天数 部分中输入以下信息。


    配置

    描述

    显示名称

    启用此功能。

    小数位数

    选择 0。


  6. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 1 行 1 列。

    显示“展开”

    禁用此功能。


  7. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 安全运行天数 > 安全运行天数。

  8. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的安全运行天数容器如下图所示。


../_images/daycount.png

节能减排


节能减排展示风电场站节约标煤和减少二氧化碳排放的指标数据,包含一个展示节能减排指标的多度量卡组件。通过以下步骤配置多度量卡组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,添加 二氧化碳减排 和 节约标煤。


  5. 在 图表样式 > 度量样式 部分中为各个度量输入以下信息。


    度量

    配置

    二氧化碳减排

    图标:选择 二氧化碳。
    图标颜色:选择 灰色(909090)。
    显示名称:启用此功能。
    单位名称:输入 万吨。
    小数位数:选择 0。

    故障设备数

    图标:选择 煤。
    图标颜色:选择 灰色(909090)。
    显示名称:启用此功能。
    单位名称:输入 万吨。
    小数位数:选择 0。


  6. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 1 行 2 列。

    显示“展开”

    禁用此功能。


  7. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 节能减排 > 节能减排。

  8. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的节能减排容器如下图所示。


../_images/co2.png

实时数据


实时数据展示风场的实时功率、当日发电量以及平均风速等重要信息,包含以下组件:

  • 展示实时功率的水球图

  • 展示发电量、装机容量与平均风速的多度量卡

  • 展示平均风速和发电量的混合图

水球图 —— 实时功率


水球图用于以液位的形式展示指标数据,或按百分比展示目标完成进度。更多信息,参见 水球图。通过以下步骤配置展示实时功率的水球图组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 水球图 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    度量

    选择 添加数据项,添加 实时功率。


  5. 在 图表样式 > 度量样式 > 实时功率 部分中输入以下信息。


    配置

    描述

    显示名称

    启用此功能。

    自适应单位

    启用此功能,系统将根据当前实时功率的值自动选择合适的单位。例如,实时功率过小时单位为 千瓦,实时功率过大时单位为 万千瓦。

    轴线范围

    输入 Min 0,Max 5000000。当实时功率的值小于等于 0 时水球图无液体,大于等于 5000000 时液体充满水球图。

    以百分比显示

    禁用此功能。


  6. 将光标悬停到此水球图组件上选择 添加到容器 并在容器列表中选择 实时数据 > 实时数据。

多度量卡 —— 发电量、装机容量与平均风速


  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,添加 发电量(当日) 、装机容量 和 平均风速。


  5. 在 图表样式 > 度量样式 标签页中为各个度量输入以下信息。


    度量

    配置

    发电量(当日)

    显示名称:启用此功能。
    单位名称:输入 KWh。
    小数位数:选择 0。

    装机容量

    显示名称:启用此功能。
    单位名称:输入 KW。
    小数位数:选择 0。

    平均风速

    显示名称:启用此功能。
    单位名称:输入 m/s。
    小数位数:选择 0。


  6. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 3 行 1 列。

    显示“展开”

    禁用此功能。


  7. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 实时数据 > 实时数据。

混合图 —— 发电量与平均风速


混合图用于展示数据在一段时间内的变化情况,也可用于对多组数据进行比较。更多信息,参见 混合图。通过以下步骤配置混合图:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 混合图 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Timeseries,即通用数据服务中的时序数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    维度聚合

    选择 是,以便对特定数据项进行加和、求平均、取最大或最小值等操作。

    开始时间

    指定混合图中数据的开始时间。

    结束时间

    指定混合图中数据的结束时间。

    聚合类型

    选择 avg,即对 聚合粒度 中规定时间段内的数据取平均值。

    聚合粒度

    选择 1 hour,即每 1 小时聚合一次原数据。

    占位

    选择 false。

    插补

    选择 true,即若某一时间点数据为空,系统将视此时间点与前一时间点数据相同。

    维度

    选择 添加数据项,添加 localtime。

    度量

    选择 添加数据项,添加 当日发电量 和 平均风速。


  5. 在 度量 部分中,选择平均风速右侧的 求和,并在下拉列表中选择 平均,按维度(此处为 localtime)对从数据源获取的风速数据取平均值。

  6. 在 过滤器 标签页中选择 添加 并在弹窗中输入以下信息。


    配置

    描述

    标题

    输入 日期。

    位置

    选择 标题右。

    类型

    选择 单边时间。

    粒度

    选择 日。

    联动组件字段

    选择 localtime 并确保右侧运算符为 =。


  7. 在 图表样式 > 度量样式 部分中为各个度量输入以下信息。


    度量

    配置

    当日发电量

    双 Y 轴:禁用此功能。
    小数位数:选择 0。
    图表类型:选择 柱状。
    颜色:选择 渐变 和 蓝色(0A64FF)。

    平均风速

    双 Y 轴:启用此功能,在副 Y 轴上展示平均风速数据。
    小数位数:选择 0。
    图表类型:选择 线性。
    颜色:选择 渐变 和 绿色(008580)。


  8. 在 图表样式 > 轴样式 部分中为各个坐标轴输入以下信息。


    坐标轴

    配置

    X 轴

    名称:输入空格,即不在混合图中显示 X 轴的名称。
    标签设置:选择 time,HH:mm 和 0°,将 X 轴上数据的显示样式设置为 HH:mm。

    Y 轴

    名称:输入 发电量(KWh)。
    自适应单位:启用此功能。
    轴线范围:从左到右依次输入 0,400 和 2,将 Y 轴数据的展示范围设置为 0 到 400 并将 Y 轴 2 等分。

    副 Y 轴

    名称:输入 风速(m/s)。
    自适应单位:启用此功能。
    轴线范围:从左到右依次输入 0,60 和 3,将副 Y 轴数据的展示范围设置为 0 到 60 并将副 Y 轴 3 等分。


  9. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 实时数据 > 实时数据。

  10. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的实时数据容器如下图所示。


../_images/realtime.png

完成率


完成率展示风场当月和当年发电量指标的完成状况,包含以下组件:

  • 展示发电量完成进度的环形仪表盘

  • 展示计划发电量与实际发电量的多度量卡

环形仪表盘 —— 发电量完成率


环形仪表盘用于以百分比形式展示目标的完成进度。更多信息,参见 环形仪表盘。通过以下步骤配置环形仪表盘:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,添加 计划完成率(当月至月末)。


  5. 在 图表样式 > 度量样式 部分中输入以下信息。


    配置

    描述

    显示名称

    禁用此功能。

    以百分比显示

    启用此功能。


  6. 在 图表样式 > 仪表盘样式 部分将 仪表盘粗细 设置为 10 pt。

  7. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 完成率 > 当月。

  8. 将光标悬停到环形仪表盘组件的省略号图标(…)上,选择 克隆组件。

  9. 将光标悬停到克隆出的环形仪表盘的省略号图标(…)上,选择 编辑。

  10. 在图表设置面板 数据 标签页的 度量 部分中,选择 计划完成率(当月至月末),在弹窗中重新选择 计划完成率(当年至年末) 选择 确定。

  11. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 完成率 > 当年。

多度量卡 —— 计划与实际发电量


  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,依次添加 发电量(当月) 和 计划发电量(当月至月末)。


  5. 依次选择各个度量名称左侧的箭头图标 i_rarrow 为度量配置展示在组件中的 别名。


    度量

    别名

    发电量(当月)

    输入 实际发电量。

    计划发电量(当月至月末)

    输入 计划发电量。


  6. 在 图表样式 > 度量样式 部分中为各个度量输入以下信息。


    度量

    配置

    发电量(当月)

    显示名称:启用此功能。
    单位名称:输入 KWh。
    小数位数:选择 0。

    计划发电量(当月至月末)

    显示名称:启用此功能。
    单位名称:输入 KWh。
    小数位数:选择 0。


  7. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 2 行 1 列。

    显示“展开”

    禁用此功能。


  8. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 完成率 > 当月。

  9. 在当月页签中调整容器和组件的大小和位置,让容器和组件在页面上正常显示。

  10. 将光标悬停到多度量卡组件的省略号图标(…)上,选择 克隆组件。

  11. 将光标悬停到克隆出的多度量卡的省略号图标(…)上,选择 编辑。

  12. 在图表设置面板 数据 标签页的 度量 部分中:

    • 选择 发电量(当月),在弹窗中重新选择 发电量(当年) 选择 确定 并将此数据项的 别名 设置为 实际发电量。

    • 选择 计划发电量(当月至月末),在弹窗中重新选择 计划发电量(当年至年末) 选择 确定 并将此数据项的 别名 设置为 计划发电量。

  13. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 完成率 > 当年。

  14. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的完成率容器如下图所示。


../_images/rate.png

异常设备统计


异常设备统计展示当前处于停机状态的设备数量,包含以下组件:

  • 展示停机风机数量的多度量卡

  • 展示停机升压站数量的多度量卡

多度量卡 —— 停机风机数量


  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 多度量卡 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板的 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    度量

    选择 添加数据项,依次添加 长停时长类型 3 风机数 和 长停时长类型 4 风机数。


  5. 依次选择各个度量名称左侧的箭头图标 i_rarrow 为度量配置展示在组件中的 别名。


    度量

    别名

    长停时长类型 3 风机数

    输入 停机 2~7 天。

    长停时长类型 4 风机数

    输入 停机 7~14 天。


  6. 在 图表样式 > 度量样式 标签页中为各个度量输入以下信息。


    度量

    配置

    长停时长类型 3 风机数

    图标:选择 风机 - 单个 1。
    显示名称:启用此功能。
    小数位数:选择 0。
    对齐方式:选择 两端对齐。
    名称位置:选择 左侧。
    使用填充色:启用此功能。
    名称框填充色:选择 黄色(F5D000) 并适当调整颜色的透明度。

    长停时长类型 4 风机数

    图标:选择 风机 - 单个 1。
    显示名称:启用此功能。
    小数位数:选择 0。
    对齐方式:选择 两端对齐。
    名称位置:选择 左侧。
    使用填充色:启用此功能。
    名称框填充色:选择 橙色(FAA228) 并适当调整颜色的透明度。


  7. 在 图表样式 > 多度量卡 部分中输入以下信息。


    配置

    描述

    布局

    设置为 2 行 1 列。

    显示“展开”

    禁用此功能。


  8. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 异常设备统计 > 异常设备统计。

多度量卡 —— 停机升压站数量


  1. 将光标悬停到展示停机风机数量的多度量卡组件的省略号图标(…)上,选择 克隆组件。

  2. 将光标悬停到克隆出的多度量卡的省略号图标(…)上,选择 编辑。

  3. 在图表设置面板 数据 标签页的 度量 部分中:

    • 选择任一度量,在弹窗中重新选择 总活跃告警数 选择 确定 并将此数据项的 别名 设置为 升压站停机 > 8小时。

    • 删除另一度量。

  4. 在图表设置面板 图表样式 标签页的 度量样式 > 总活跃告警数 部分中将 名称框填充色 修改为 红色(F54E5F) 并适当调整颜色的透明度。

  5. 将光标悬停到此多度量卡组件上选择 添加到容器 并在容器列表中选择 异常设备统计 > 异常设备统计。

  6. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的异常设备统计容器如下图所示。


../_images/error.png

资产排行


资产排行展示场站关键指标的排名情况,包含一个表格组件。表格组件用于以表格形式展现各资产的属性、测点或指标。更多信息,参见 表格。通过以下步骤配置展示各场站指标排名的表格组件:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 组件 打开新建组件弹窗。

  2. 在 新组件 标签页中选择 表格 并选择 确定 将组件添加到页面中。组件添加到页面后,页面右侧自动展开图表设置面板。

  3. 在右侧图表设置面板 基本 标签页中勾选 隐藏标题。

  4. 在 数据项 标签页中输入以下信息。


    配置

    描述

    数据源

    选择 Realtime,即通用数据服务中的实时数据。

    类别

    选择 EnOS_Wind_Farm,指定此组件展示风场的相关数据。

    自动获取资产

    选择 true,自动获取 EnOS_Wind_Farm 下所有资产的数据。

    维度

    选择 添加数据项,添加 assetName。

    度量

    选择 添加数据项,依次添加 装机容量、当日发电量(万KWh)、当月发电量(万KWh)、当年发电量(万KWh)、当年计划完成率 和 故障设备数。


  5. 依次选择各个维度和度量名称左侧的箭头图标 i_rarrow 为度量配置展示在组件中的 别名。


    维度/度量

    别名

    assetName

    输入 场站名称。

    装机容量

    输入 装机容量。

    当日发电量(万KWh)

    输入 当日发电量。

    当月发电量(万KWh)

    输入 当月发电量。

    当年发电量(万KWh)

    输入 当年发电量。

    当年计划完成率

    输入 计划完成率。

    故障设备数

    输入 故障设备数。


  6. 在 图表样式 > 表格样式 > 表头 部分中输入以下信息。


    配置

    描述

    可排序列

    选择 全部,即所有列均可进行升序或降序排列。

    对齐方式

    选择 左对齐。


  7. 将光标悬停到此表格组件上选择 添加到容器 并在容器列表中选择 资产排行 > 场站排行。

  8. 调整容器和组件的大小和位置,让容器和组件在页面上正常显示。


配置完成的资产排行容器如下图所示。


../_images/rank.png

(可选)步骤 4:添加全局过滤器


终端用户可通过全局过滤器过滤岗位工作台页面中多个组件的数据。同时,若需要将此岗位工作台页面关联到统一监测的 可配置页面 中,应用构建者必须添加全局过滤器并输入特定的键值,才能让终端用户通过可配置页面中的过滤器过滤资产和数据。更多信息,参见 可配置页面输出参数。


全局过滤器 —— 按场站名称过滤


此全局过滤器显示在岗位工作台页面上,用于让终端用户按场站名称过滤岗位工作台展示的场站和相关数据。通过以下步骤添加按场站名称过滤场站的全局过滤器:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 全局过滤器 打开全局过滤器弹窗。

  2. 在弹窗左侧选择 添加过滤器 并在弹窗右侧输入以下信息。


    配置

    描述

    标题

    输入 场站名称过滤器。

    键值

    输入 siteName。

    属性

    勾选 页面可见,让此过滤器显示在岗位工作台页面顶部。[1]

    搜索提示

    输入 输入场站名称。

    过滤器类型

    选择 搜索。

    联动数据源

    选择 添加,在弹窗中选择 Realtime 作为数据源,EnOS_Wind_Farm 作为数据集,assetName 作为数据项并选择 确定。

    组件范围

    选择 排除 并将右侧文本框留空,表示此过滤器可过滤页面中所有组件的数据。


  3. 选择 确定 添加过滤器。


[1] 对于需要展示在可配置页面中的指标页面,建议禁用 页面可见 并启用可配置页面中的过滤器。

全局过滤器 —— 按场站 ID 过滤


此全局过滤器主要用于在将岗位工作台页面关联到可配置页面后,确保终端用户可以通过可配置页面中的过滤器过滤页面资产。通过以下步骤添加按场站 ID 过滤场站的全局过滤器:

  1. 在页面编辑器的顶部工具栏中,选择 添加 > 全局过滤器 打开全局过滤器弹窗。

  2. 在弹窗左侧选择 添加过滤器 并在弹窗右侧输入以下信息。


    配置

    描述

    标题

    输入 场站 ID 过滤器。

    键值

    输入 mdmIds。

    属性

    启用 接受外部参数,让此过滤器可以接收可配置页面传递的参数信息(此处即为场站 ID)。
    禁用 页面可见,此过滤器仅作为与可配置页面传递数据的桥梁,无需在页面中显示。

    过滤器类型

    选择 搜索。

    联动数据源

    选择 添加,在弹窗中选择 Realtime 作为数据源,EnOS_Wind_Farm 作为数据集,[P]mdmId 作为数据项并选择 确定。

    组件范围

    选择 包含,选择右侧文本框并在下拉列表中选择 场站排行,表示此过滤器仅过滤场站排行容器中的数据。


  3. 选择 确定 添加过滤器。


上述配置完成后,终端用户可以在页面上方的 场站名称 输入框中输入场站名称,让岗位工作台页面仅显示特定场站的相关数据,或在相关可配置页面中使用相应过滤器过滤数据。

步骤 5:发布页面


岗位工作台页面配置完成后,通过以下步骤发布此页面,以便让终端用户在线访问岗位工作台:

  1. 在页面编辑器的顶部工具栏中,选择 保存 > 保存并发布 打开发布弹窗。

  2. 在弹窗中输入以下信息。


    配置

    描述

    可见范围

    选择 内部。

    数据来源

    选择 实际数据。


  3. 选择 确定 发布页面。


下一步


页面发布成功后,弹窗中将显示此页面的发布路径。复制此路径,应用构建者可以:

  • 直接在浏览器中访问此路径。

  • 在应用门户管理后台中创建应用快捷方式,并将此路径添加到应用菜单中。更多信息,参见 管理应用快捷方式。

  • 在统一监测组件的可配置页面中关联此路径,将岗位工作台关联到可配置页面中。更多信息,参见 可配置页面。